Download Anarcho Ride

How to update & Release notes

I want to update to the latest version and keep my highscores - USING HARDDRIVE
I want to update to the latest version and keep my highscores - USING FLOPPYS
I have two floppy drives A/B. Can I use them both?
Beta 0.9
Beta 0.93 - 2015 October 24
Beta 0.932 - 2015 October 31
RC 0.941 - 2015 November 2
V 1.00 - 2015 November 9
V 1.00a - 2015 November 17
V 1.01 - 2015 December 20
V 1.02 - 2016 January 12
V 1.03 - 2016 June 26
V 1.03A - 2016 July 2
V 1.04 - 2016 October 7

System requirements

ATARI STe/Falcon or compatible ATARI ST emulator.
Colour monitor. Or switch emulator to Low resolution mode.
RAM STe: 2MB recommended/1MB minimum
(enter setup on start-up to switch to 1MB mode)
RAM Falcon: 4MB minimum
Harddrive recommended for convenience and shorter loading times
(Floppy version comes with setup utility)
If available use 16Mhz or higher (Falcon & MEGA STe).

HELP! I only have an ATARI ST

No E or FALCON printed on it!
What can I do?
Answer: Get yourself an STe or Click Here

Weekend vacation...

Caution: slippery in the snow!

Robot cars never crash?

London traffic...

00000532